]> Frank Brehm's Git Trees - portage.git/commitdiff
Adding games-misc/asciiquarium/asciiquarium-1.1.ebuild
authorFrank Brehm <frank@brehm-online.com>
Sun, 31 Jul 2016 06:17:37 +0000 (08:17 +0200)
committerFrank Brehm <frank@brehm-online.com>
Sun, 31 Jul 2016 06:17:37 +0000 (08:17 +0200)
games-misc/asciiquarium/Manifest [new file with mode: 0644]
games-misc/asciiquarium/asciiquarium-1.1.ebuild [new file with mode: 0644]

diff --git a/games-misc/asciiquarium/Manifest b/games-misc/asciiquarium/Manifest
new file mode 100644 (file)
index 0000000..25f2c60
--- /dev/null
@@ -0,0 +1,2 @@
+DIST asciiquarium_1.1.tar.gz 15436 SHA256 1b08c6613525e75e87546f4e8984ab3b33f1e922080268c749f1777d56c9d361 SHA512 109da0aaba272465aa2cf5ce010e9ca1ece3be5be996dfe12709b3c10e44572492196b1852e8c103ed89d2c6efd0b05e454a718267cbcc4924806d30a072d926 WHIRLPOOL 968020520c5f2a4de60870327d575233ee8d90af0bcb6666ddb0d0002cd29550f2a1caaf69022a80cbf661d258a4e35f17e5b73a08fb655d72cbf67246ec58d2
+EBUILD asciiquarium-1.1.ebuild 704 SHA256 fe100958d30ba950bda4d6174b71b7c91731088f68ae701fac53467f1eb147f3 SHA512 cd2971572d2e74b6c32f12f450295ee3ccd20c02a95bc97f2dcfb446d4f1b6fabb3a8229a98d10539fe3497e86ead615b4b1d2f2177052981e8ba5c32f21d944 WHIRLPOOL 3204a6933590091c4d747e007a661dfcc9a17a42cd250126100fe6e04557bd754f08a2a95864f4b88af9362561180748159dc849234eb7185cb420b1edb74afe
diff --git a/games-misc/asciiquarium/asciiquarium-1.1.ebuild b/games-misc/asciiquarium/asciiquarium-1.1.ebuild
new file mode 100644 (file)
index 0000000..3a1985b
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit games
+
+DESCRIPTION="An aquarium/sea animation in ASCII art."
+HOMEPAGE="http://www.robobunny.com/projects/asciiquarium/html"
+SRC_URI="http://www.robobunny.com/projects/asciiquarium/${PN}_${PV}.tar.gz"
+
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE=""
+
+DEPEND=">=dev-perl/Term-Animation-2.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}_${PV}"
+
+src_compile() {
+       einfo "Nothing to compile here."
+}
+
+src_install() {
+       install -D --preserve-timestamps asciiquarium "${D}${GAMES_BINDIR}/asciiquarium"
+       dodoc CHANGES MANIFEST README gpl.txt
+       prepgamesdirs
+}
+