]> Frank Brehm's Git Trees - portage.git/commitdiff
Add dev-python/profitbricks-sdk/profitbricks-sdk-2.3.0.ebuild
authorFrank Brehm <frank.brehm@profitbricks.com>
Mon, 25 Jan 2016 12:32:43 +0000 (13:32 +0100)
committerFrank Brehm <frank.brehm@profitbricks.com>
Mon, 25 Jan 2016 12:32:43 +0000 (13:32 +0100)
dev-python/profitbricks-sdk/Manifest [new file with mode: 0644]
dev-python/profitbricks-sdk/profitbricks-sdk-2.3.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/profitbricks-sdk/Manifest b/dev-python/profitbricks-sdk/Manifest
new file mode 100644 (file)
index 0000000..5167946
--- /dev/null
@@ -0,0 +1 @@
+EBUILD profitbricks-sdk-2.3.0.ebuild 804 SHA256 ca7f503789eb41d1bddca0730fd59c30203f465b80f68cda59043f44a7753500 SHA512 e1c3b220638b6aad24885cee1afad49650b9636c71de79fe28383ef4af677181684147f02cff9c27d5f4c31fb3f3a8008fb2b82dba8b89af4137cd21ead339d9 WHIRLPOOL 617d77da3db5a30cbbeccdc425c1add67ff1c5f23fd04d8b04253884167e9677e386771a75aef0d373d14d3f766ddd0699f2a7523914aeeaacc04efe50b65096
diff --git a/dev-python/profitbricks-sdk/profitbricks-sdk-2.3.0.ebuild b/dev-python/profitbricks-sdk/profitbricks-sdk-2.3.0.ebuild
new file mode 100644 (file)
index 0000000..5aa221a
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy2_0 )
+
+DESCRIPTION="ProfitBricks REST API client library for Python"
+HOMEPAGE="https://github.com/profitbricks/profitbricks-sdk-python"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/profitbricks/profitbricks-sdk-python.git"
+
+inherit git-2 distutils-r1 versionator
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+EGIT_BRANCH="master"
+EGIT_COMMIT="v$(replace_version_separator 3 '-')"
+
+DOCS="LICENSE README.md requirements.txt"
+
+RDEPEND="
+       dev-python/six
+       >=dev-python/requests-2.8.0
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       elog "Used GIT tag: '${EGIT_COMMIT}'."
+       distutils-r1_src_prepare
+}
+
+
+# vim: filetype=ebuild ts=4 sw=4