]> Frank Brehm's Git Trees - portage.git/commitdiff
Add dev-python/profitbricks-sdk/profitbricks-sdk-2.3.1.1.ebuild
authorFrank Brehm <frank.brehm@profitbricks.com>
Tue, 2 Feb 2016 10:46:34 +0000 (11:46 +0100)
committerFrank Brehm <frank.brehm@profitbricks.com>
Tue, 2 Feb 2016 10:46:34 +0000 (11:46 +0100)
dev-python/profitbricks-sdk/Manifest
dev-python/profitbricks-sdk/profitbricks-sdk-2.3.1.1.ebuild [new file with mode: 0644]

index adf07861df4cd67937b15f4dc717a14eb79e1c87..114e2655ab95b411b6815d49454e3d058b4f740d 100644 (file)
@@ -1,2 +1,3 @@
 EBUILD profitbricks-sdk-2.3.0.1.ebuild 799 SHA256 ae9c373691ff1815631c44f038c3de10d364f14df810a04950ccebab427d6a65 SHA512 1620de7ca549a36153b7f68367bc48f50f2d28f3e0e7fa91ac843b51af7e5e182f5fd075e4b9811b9c604db640468e615cd43222bcd2170d2449cb946e5007fc WHIRLPOOL 26ce1bfed00985a7bf9822aa3222e20423522ddcb9d0e561f3ad0c06d87278a0acc67db997742522e806554962af6b85c3ca7b99f5407d71f660257384768efb
 EBUILD profitbricks-sdk-2.3.0.ebuild 802 SHA256 ac3385069061110e400dcb784b3c287bee0a40494e418a39c2b1032d98ec6d90 SHA512 fbc84ff16cef4214fb11d2f32c266cda4914a5373ad4c6194f072cc4a69ec31f23844d2669ffd56501ae8ca82a09bbf721efa3f9b320a64819835015c06a163c WHIRLPOOL d321c5b2f966e7967a8064310b77a39315f3d6adfd9a1f8e0b0a81db852ff6be7651d960dd9ff54e5f179bfc154d817cb70c7c5f859f7806794b56112d2c9556
+EBUILD profitbricks-sdk-2.3.1.1.ebuild 999 SHA256 54c5dac2362345264609b7f4ec10fc1054913b8769b07e02832201fe97e07afa SHA512 4fde95de9b9dbf51b147b14085cc5e2aff22b55a714199f41118d418c8e2c8e48f4189bcef7a224bbc4ae481f8fa45815c668966c94783e4045caaff77b60a52 WHIRLPOOL 3ac5b563036b7b4c66f1effc1b57e63c2cf2867f8044be278ced21c1f67dc63de88e7d6c47d44677db2251012209767a47f46d669e3128169e1a1dd2754d650f
diff --git a/dev-python/profitbricks-sdk/profitbricks-sdk-2.3.1.1.ebuild b/dev-python/profitbricks-sdk/profitbricks-sdk-2.3.1.1.ebuild
new file mode 100644 (file)
index 0000000..b5fa4dd
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4,3_5} pypy2_0 )
+
+DESCRIPTION="ProfitBricks REST API client library for Python"
+HOMEPAGE="https://github.com/profitbricks/profitbricks-sdk-python"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/fbrehm/profitbricks-sdk-python.git"
+
+inherit git-2 distutils-r1 versionator
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+EGIT_BRANCH="master"
+EGIT_COMMIT="$(replace_version_separator 4 '-')"
+
+DOCS="LICENSE README.md requirements.txt"
+
+RDEPEND="
+       dev-python/six
+       >=dev-python/requests-2.8.0
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       elog "Used GIT tag: '${EGIT_COMMIT}'."
+       distutils-r1_src_prepare
+}
+
+src_install() {
+
+       distutils-r1_src_install
+
+    if use examples ; then
+               docompress -x /usr/share/doc/${PF}/examples
+        insinto /usr/share/doc/${PF}
+        doins -r examples
+    fi
+
+
+}
+
+
+# vim: filetype=ebuild ts=4 sw=4