]> Frank Brehm's Git Trees - portage.git/commitdiff
Removing dev-python/pb-blockdev/pb-blockdev-0.3.4.1.ebuild, updating dev-python/pb...
authorFrank Brehm <frank@brehm-online.com>
Mon, 15 May 2017 09:50:56 +0000 (11:50 +0200)
committerFrank Brehm <frank@brehm-online.com>
Mon, 15 May 2017 09:50:56 +0000 (11:50 +0200)
dev-python/pb-blockdev/Manifest
dev-python/pb-blockdev/pb-blockdev-0.3.4.1.ebuild [deleted file]
dev-python/pb-blockdev/pb-blockdev-0.3.5.1.ebuild

index 6e40424dac574fcb09dffa69be31f9fb21d0c2d3..e06495f534e118570790b660ecf8c0376057540b 100644 (file)
@@ -1,2 +1 @@
-EBUILD pb-blockdev-0.3.4.1.ebuild 1848 SHA256 1af9178eb9f9eefbfdef2c464b1c6af7b9169d38aa213966945c70517353f87f SHA512 edd01608fc53488245d4148359ddeb8c9e42aaafa3d111a28a031589e20ed133b0860d6ee6f1a6ee1e108edfbfca314549d5e9d25ab334bcb16e900237040ae3 WHIRLPOOL f1cd34fe82de0c4e765e3b8c7e38a3dfb6a0409a4408368d6e9d6565f921ee661742c4834261b060ebca457108eb57868f06e99dd307a75f1b963589efeee2dc
-EBUILD pb-blockdev-0.3.5.1.ebuild 1851 SHA256 18498c822739d6d119c76f9383dcb3deff826988e49992f2c0e5580d696d01f3 SHA512 cfd1b921a235854bbe6496faab0f669331836fb569961fa1902d5bd824d5e456ed5a38f7bc270892adbd64b2ba992f2e0870539cc0c3a76cbf711074ae5a42cd WHIRLPOOL f91c50379de26ba87c9eda76b2d804664263ad0e72cd1ea0ed74d8d401e797215d0f1373df5a1edc87c61884e59f65e1ff1a55210a04e0afc6a66271e917b2b2
+EBUILD pb-blockdev-0.3.5.1.ebuild 1757 SHA256 832de199510b97c9a040461a8838dd21e155bc60626ab1bfbee8ed4dd5ac4a58 SHA512 bd10994f71f6343b4c69d69546e4d5fbcfccaed9ffaffbb7e1073f254a4cb56671cb75678142ad19e9e5f9170b11f5af108ea0d275d771590cc4276ed19e95f0 WHIRLPOOL bd192ee70a52fb01845ba3db091aa4bde463d1be610bcb698eb7cf3e7ad41be1c63933aeaf45180c4f68f532dc882eebc9b1944ff78ebb4febc0b231b093e3ca
diff --git a/dev-python/pb-blockdev/pb-blockdev-0.3.4.1.ebuild b/dev-python/pb-blockdev/pb-blockdev-0.3.4.1.ebuild
deleted file mode 100644 (file)
index 21530e8..0000000
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-DESCRIPTION="Python modules for common used wrapper classes for different block devices."
-HOMEPAGE="https://github.com/fbrehm/py-pb-blockdev"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/fbrehm/py-pb-blockdev.git"
-
-inherit git-2 distutils user python versionator
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc nls"
-PYTHON_DEPEND="2::2.7"
-
-EGIT_BRANCH="master"
-EGIT_COMMIT=$(replace_version_separator 3 '-')
-
-DOCS="debian/changelog README.txt"
-
-RDEPEND="
-       >=dev-python/pb-logging-0.2.7
-       >=dev-python/pb-base-0.4.10
-       >=dev-python/pyparted-3.8
-       nls? ( virtual/libintl )
-"
-DEPEND="
-       ${RDEPEND}
-       doc? (  dev-python/epydoc 
-                       dev-python/docutils
-                       dev-texlive/texlive-latexextra
-       )
-       nls? ( sys-devel/gettext )
-"
-
-pkg_setup() {
-
-       elog "Used GIT tag: '${EGIT_COMMIT}'."
-
-       elog "Start setup package ..."
-       python_set_active_version 2
-       python_pkg_setup
-}
-
-src_compile() {
-       elog "Start compiling package ..."
-       distutils_src_compile
-       if use nls; then
-               make -C ${S}/po
-       fi
-}
-
-src_install() {
-       distutils_src_install
-       #python_clean_installation_image
-
-       if use doc; then
-               einfo "Installing documentation ..."
-               dodir "/usr/share/doc/${PF}"
-               dodir "/usr/share/doc/${PF}/html"
-               dodir "/usr/share/doc/${PF}/pdf"
-
-               einfo "Creating epydoc html documentation"
-               epydoc --html -v -o "${ED}/usr/share/doc/${PF}/html" "${S}/pb_blockdev" || ewarn "Could not create epydoc html documentation"
-               einfo "Creating epydoc pdf documentation"
-               epydoc --pdf -o "${ED}/usr/share/doc/${PF}/pdf" "${S}/pb_blockdev" || ewarn "Could not create epydoc pdf documentation"
-
-       fi
-
-#      if use nls; then
-#              make -C ${S}/po DESTDIR="${ED}" install
-#      fi
-
-}
-
-pkg_postinst() {
-       python_mod_optimize pb_blockdev
-}
-
-pkg_postrm () {
-    python_mod_cleanup pb_blockdev
-}
-
-
index 13122b7db7725416ba3c8852de647b369abe2c07..5032dc5d058af80a970457733d37fd57bb93aaa5 100644 (file)
@@ -1,20 +1,20 @@
 # Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4,3_5} pypy2_0 )
 
 DESCRIPTION="Python modules for common used wrapper classes for different block devices."
 HOMEPAGE="https://github.com/fbrehm/py-pb-blockdev"
 SRC_URI=""
 EGIT_REPO_URI="https://github.com/fbrehm/py-pb-blockdev.git"
 
-inherit git-2 distutils user python versionator
+inherit git-2 distutils-r1 user versionator
 
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="doc nls"
-PYTHON_DEPEND="2::2.7"
 
 EGIT_BRANCH="develop"
 EGIT_COMMIT=$(replace_version_separator 3 '-')
@@ -41,21 +41,20 @@ pkg_setup() {
        elog "Used GIT tag: '${EGIT_COMMIT}'."
 
        elog "Start setup package ..."
-       python_set_active_version 2
-       python_pkg_setup
+       distutils-r1_src_prepare
 }
 
 src_compile() {
        elog "Start compiling package ..."
-       distutils_src_compile
+       distutils-r1_src_compile
        if use nls; then
                make -C ${S}/po
        fi
 }
 
 src_install() {
-       distutils_src_install
-       #python_clean_installation_image
+       einfo "Start installing package ..."
+       distutils-r1_src_install
 
        if use doc; then
                einfo "Installing documentation ..."
@@ -70,18 +69,10 @@ src_install() {
 
        fi
 
-#      if use nls; then
-#              make -C ${S}/po DESTDIR="${ED}" install
-#      fi
-
-}
-
-pkg_postinst() {
-       python_mod_optimize pb_blockdev
-}
+       if use nls; then
+               make -C ${S}/po DESTDIR="${ED}" install
+       fi
 
-pkg_postrm () {
-    python_mod_cleanup pb_blockdev
 }