]> Frank Brehm's Git Trees - portage.git/commitdiff
Adding dev-python/pyexiv2/pyexiv2-0.3.0-r3.ebuild and dependencies
authorFrank Brehm <frank@brehm-online.com>
Sun, 18 Sep 2016 15:15:42 +0000 (17:15 +0200)
committerFrank Brehm <frank@brehm-online.com>
Sun, 18 Sep 2016 15:15:42 +0000 (17:15 +0200)
dev-python/pyexiv2/Manifest [new file with mode: 0644]
dev-python/pyexiv2/files/pyexiv2-0.3.0-docs.patch [new file with mode: 0644]
dev-python/pyexiv2/pyexiv2-0.3.0-r3.ebuild [new file with mode: 0644]

diff --git a/dev-python/pyexiv2/Manifest b/dev-python/pyexiv2/Manifest
new file mode 100644 (file)
index 0000000..bad7a7c
--- /dev/null
@@ -0,0 +1,3 @@
+AUX pyexiv2-0.3.0-docs.patch 299 SHA256 d31735a8e04aa2e92b31644cfc42c19c45846ee6ddb23b884d67faf0a5ccb41d SHA512 17ed028a658feeceb657a43fa4c5affee30d60eb991bffcd3d78397f043f543e2850e8f2cc9b4b8d88bfa8d7bbbe33cbe1206644defb27f188d76cf2400fb2be WHIRLPOOL e4948a19bb7a9dfa52474bbccf8932c12fdfa942e7e5818cc956a004fdbcd61a969faa8a82e7c1f1299c8ef92c91c139f919a84af8590343d4f1da37fc9b44e5
+DIST pyexiv2-0.3.0.tar.bz2 202714 SHA256 e96549feab366de85070aa2f8cedcc4d0017d53b78faea5067c60425c117f9f8 SHA512 b33261ada3598ab2a4c91dc6693d70e1e3799900b2d96af89ea37ba63fcf0a72571108383875fc71c07f15d4d174b538212683a8f6eb4018d0b95b58965d2194 WHIRLPOOL 3f4f7a5aebf416395ccb239304809f2f88c498787177a618c838d7f7498e137b6b854eb1f89e0644ecbf89ce2d4f254f618bc5246f66c831f09fd0f2730071e5
+EBUILD pyexiv2-0.3.0-r3.ebuild 1115 SHA256 e9030330b6885e987a6890ba8c3bb2048141842836a63a75c132057aa0634fa0 SHA512 4780505460d7c8d87e4142279b22ca0a861ee2b236a286985ab5cc582d50ffe59aad484e1a6628c5cd4613db707d5b4dd3743065d2412b39b76c95a489abdedd WHIRLPOOL ff62f07aba1f3e0b5003b9df50743d6e20ff02e42cce3de1bf931fef73e93741f536f213fad8b83347a6274b985a7c9679c6f1828f93f68c3de19375b7bdc163
diff --git a/dev-python/pyexiv2/files/pyexiv2-0.3.0-docs.patch b/dev-python/pyexiv2/files/pyexiv2-0.3.0-docs.patch
new file mode 100644 (file)
index 0000000..dffb3a6
--- /dev/null
@@ -0,0 +1,11 @@
+--- doc/SConscript.orig
++++ doc/SConscript
+@@ -20,7 +20,7 @@
+           for doc in sphinx.builder.get_outdated_docs()]
+ def build_doc(target, source, env):
+-    sphinx.build(all_files=False, filenames=[])
++    sphinx.build(False, filenames=[])
+     return sphinx.statuscode
+ env = Environment()
diff --git a/dev-python/pyexiv2/pyexiv2-0.3.0-r3.ebuild b/dev-python/pyexiv2/pyexiv2-0.3.0-r3.ebuild
new file mode 100644 (file)
index 0000000..143d720
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils versionator scons-utils python-r1
+
+MY_PV=$(get_version_component_range 1-2)
+DESCRIPTION="Python binding to exiv2"
+HOMEPAGE="http://tilloy.net/dev/pyexiv2/"
+SRC_URI="http://launchpad.net/${PN}/${MY_PV}.x/${MY_PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND="
+       >=media-gfx/exiv2-0.20
+       dev-python/sphinx[${PYTHON_USEDEP}]
+       dev-libs/boost[python,${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       epatch "${FILESDIR}"/${P}-docs.patch
+}
+
+src_compile() {
+       escons BOOSTLIB=boost_python-2.7 lib
+       if use doc; then
+               escons doc
+
+               # To enable doins -r in src_install
+               rm -R doc/_build/.doctrees || die
+       fi
+}
+
+src_install() {
+       escons BOOSTLIB=boost_python-2.7 DESTDIR="${D}" install
+       dodoc NEWS README todo
+
+       if use examples; then
+               insinto /usr/share/${PN}/examples
+               doins src/*example*.py
+       fi
+
+       if use doc; then
+               docinto html
+               dodoc -r doc/html/*
+       fi
+       python_foreach_impl python_optimize
+}